Uploaded image for project: 'Jackrabbit Oak'
  1. Jackrabbit Oak
  2. OAK-8964

oak-run: UtilsTest fails when Mongo not present

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.8.21
    • Fix Version/s: 1.8.22
    • Component/s: run
    • Labels:
      None

      Description

      [ERROR] Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 3.004 s <<< FAILURE! - in org.apache.jackrabbit.oak.run.UtilsTest
      [ERROR] validateMongoUri(org.apache.jackrabbit.oak.run.UtilsTest) Time elapsed: 3.004 s <<< ERROR!
      com.mongodb.MongoTimeoutException: Timed out after 3000 ms while waiting to connect. Client view of cluster state is {type=UNKNOWN, servers=[{address=127.0.0.1:27017, type=UNKNOWN, state=CONNECTING, exception=

      {com.mongodb.MongoSocketOpenException: Exception opening socket}

      , caused by {java.net.ConnectException: Connection refused: connect}}]
      at org.apache.jackrabbit.oak.run.UtilsTest.validateMongoUri(UtilsTest.java:38)

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mreutegg Marcel Reutegger
                Reporter:
                reschke Julian Reschke
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: