Resolution: Won't Fix
Affects Version/s: None
Fix Version/s: None
while trying to simplify the property-index definitions and adding
one for the access control content, i detected the following inconsistencies
with the property "propertyNames":
- the property is sometimes single valued (e.g. "uuid") and sometimes
IMO the property name implies that it is multivalued. however, i get the
impression that this doesn't work for unique property index definitions.
- the property is defined using Type.STRING (implicit) or Type.STRINGS.
IMO however, Type.NAMES would be more appropriate.
- while moving out the user related index, i used type name without noticing.
i will change to STRING(S) such that we have it consistent (see above).