Uploaded image for project: 'Jackrabbit Oak'
  1. Jackrabbit Oak
  2. OAK-5215

remove use of deprecated guava methods

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.4.10, 1.5.14
    • Fix Version/s: 1.5.15, 1.6.0, 1.4.25
    • Component/s: None
    • Labels:
      None

      Description

      When running in a non-osgi environment it's sometimes necessary to use a more recent version of the guava dependency due to requirements of other components. By changing the use of methods that are deprecated in later version of guava, eg. v 19.0, it is possible to use any guava version between 15.0 (current) and 19.0.

        Attachments

        1. guava.patch
          8 kB
          Torgeir Veimo
        2. OAK-5115.patch
          8 kB
          Alex Deparvu

          Activity

            People

            • Assignee:
              stillalex Alex Deparvu
              Reporter:
              torgeir@pobox.com Torgeir Veimo
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: