Nutch
  1. Nutch
  2. NUTCH-1362

Fix error handling of urls with empty fields

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: nutchgora
    • Fix Version/s: nutchgora
    • Component/s: None
    • Labels:
      None

      Description

      Within o.a.n.util.TableUtil.reverseAppendSplits() a simple if (split.length > 0) block enables us to address this issue.

        Activity

        Lewis John McGibbney created issue -
        Ferdy Galema added a comment -

        Hey Lewis,

        This patches fixes the problem and makes the reversing a bit faster by using StringUtils.split instead of String.split. (The latter compiles a regular expression every time a split is done. That's a bit excessive for simple dot and colon splitting.)

        Tested and verified.

        Ferdy Galema made changes -
        Field Original Value New Value
        Attachment NUTCH-1362.patch [ 12526497 ]
        Ferdy Galema added a comment -

        Btw this is a duplicate of NUTCH-1077.

        Lewis John McGibbney added a comment -

        +1 to commit Ferdy. I am happy with this and simplification.

        Ferdy Galema added a comment -

        Done! Thanks.

        Ferdy Galema made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Hudson added a comment -

        Integrated in Nutch-nutchgora #250 (See https://builds.apache.org/job/Nutch-nutchgora/250/)
        NUTCH-1362 Fix error handling of urls with empty fields (Revision 1337091)

        Result = SUCCESS
        ferdy :
        Files :

        • /nutch/branches/nutchgora/CHANGES.txt
        • /nutch/branches/nutchgora/src/java/org/apache/nutch/util/TableUtil.java

          People

          • Assignee:
            Unassigned
            Reporter:
            Lewis John McGibbney
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development