Nutch
  1. Nutch
  2. NUTCH-1311

Add response headers to datastore for the protocol-httpclient plugin

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: nutchgora
    • Fix Version/s: nutchgora
    • Component/s: fetcher
    • Labels:
      None

      Description

      Response Headers need to be added to the page to add to the datastore for this plugin

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        4h 10m 1 Ferdy Galema 16/Mar/12 15:11
        Hudson added a comment -

        Integrated in Nutch-nutchgora #197 (See https://builds.apache.org/job/Nutch-nutchgora/197/)
        NUTCH-1311 Add response headers to datastore for the protocol-httpclient plugin (Revision 1301476)

        Result = SUCCESS
        ferdy :
        Files :

        • /nutch/branches/nutchgora/CHANGES.txt
        • /nutch/branches/nutchgora/src/plugin/protocol-httpclient/src/java/org/apache/nutch/protocol/httpclient/HttpResponse.java
        Ferdy Galema made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Ferdy Galema added a comment -

        Ok I'll close this one. To not lose sight of the issue for trunk, I have created NUTCH-1313.

        Dan Rosher added a comment -

        Sorry ... I inadvertently had it affect trunk, this patch was intended only for nutchgora, I've edited issue to reflect this.

        Dan Rosher made changes -
        Affects Version/s 1.5 [ 12318246 ]
        Markus Jelsma added a comment -

        Hi, HTTP response headers are available as Content metadata in trunk.

        Ferdy Galema added a comment -

        Tested and committed at Nutchgora branch. Thanks for the patch. (A minor nit: you are using tabs instead of spaces).

        Please note that it does not apply to trunk. The implementation will be very different because WebPage does not exist in trunk. If you want to you can either create a patch for trunk too, or simply close this one off so we can solve it for trunk in a separate issue.

        Ferdy Galema added a comment -

        This is indeed useful. I can commit this when I verified the contents.

        Dan Rosher made changes -
        Field Original Value New Value
        Attachment NUTCH-1311.patch [ 12518653 ]
        Dan Rosher created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Dan Rosher
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development