Uploaded image for project: 'Nutch'
  1. Nutch
  2. NUTCH-1200

Resolving Ivy dependencies in several plugins

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Not A Problem
    • Affects Version/s: 1.4
    • Fix Version/s: 1.5
    • Component/s: build
    • Labels:
      None
    • Patch Info:
      Patch Available

      Description

      When configuring Nutch 1.5-SNAPSHOT in Eclipse, I noticed that any plugins requiring additional libraries OVER AND ABOVE the ones specified in NUTCH_HOME/ivy/ivy.xml cannot resolve the dependencies. In specific the classes are

      - FeedParser <dependency org="net.java.dev.rome" name="rome" rev="1.0.0" conf="*->master"/>
      - URLAutomationFilter - <dependency org="dk.brics" name="automaton" rev="???"/>
      - SWFParser <dependency org="com.google.gwt" name="gwt-incubator" rev="2.0.1"/>
      - HTMLParser   <dependency org="net.sourceforge.nekohtml" name="nekohtml" rev="1.9.15"/> 
      

      Further to this, I cannot locate the dk.brics dependency!

      Finally, the plugin/ivy.xml files for the above plugins cannot be parsed corectly due to the ${nutch.root} vairable.

        Attachments

        1. NUTCH-1200-trunk.patch
          2 kB
          Lewis John McGibbney
        2. NUTCH-1200-v2-trunk.patch
          2 kB
          Lewis John McGibbney

          Activity

            People

            • Assignee:
              lewismc Lewis John McGibbney
              Reporter:
              lewismc Lewis John McGibbney
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: