NPanday
  1. NPanday
  2. NPANDAY-428

Issues while removing/adding a dependency in the project

    Details

      Description

      Steps to reproduce:

      1) Start NPanday
      2) Open 'ProjectA'
      3) Generate POMs
      4) Right click on 'ProjectA', then select 'Current NPanday Project > Install'
      5) Add a new 'ProjectB' to the solution
      6) Generate POMs
      7) Add 'ProjectA' as dependency to 'ProjectB' (Add Maven Artifact)
      8) Build the whole solution
      9) Remove 'ProjectA' as dependency to 'ProjectB'

      Actual Behavior:

      POM file for ProjectB was not updated correctly. Configuration for the dependency for 'ProjectA' was not removed in POM

      Expected Behavior:

      POM file for ProjectB should be updated properly.

      10) Add 'ProjectA' again to 'ProjectB'

      Actual Behavior:

      "Error in Adding Artifact Dependency.." pops up because the dependency was not removed in the POM.

        Activity

        Brett Porter made changes -
        Fix Version/s 1.5.0-incubating [ 12319165 ]
        Fix Version/s 1.4.1-incubating [ 12316342 ]
        Adelita L. Padilla made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Adelita L. Padilla added a comment -

        Fixed in r1127861.

        Adelita L. Padilla made changes -
        Field Original Value New Value
        Assignee Adelita L. Padilla [ apadilla ]
        Adelita L. Padilla created issue -

          People

          • Assignee:
            Adelita L. Padilla
            Reporter:
            Adelita L. Padilla
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development