Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.1
    • Fix Version/s: 1.4-incubating
    • Component/s: Repository
    • Labels:
      None
    • Environment:

      1.2.2-incubating

      Description

      This plugin has size 0 in repo, and make impossible to use npanday 1.2.2-incubating

      Name: NPanday.Plugin-1.2.2-incubating-20101021.032458-5-4b435f4d76e2f0e6.dll
      Size: 0 Bytes

      3K downloaded (NPanday.Plugin-1.2.2-incubating-20101021.032458-5.pom)
      27-ott-2010 9.56.43 npanday.dao.impl.ProjectDaoImpl storeProjectAndResolveDependencies
      INFO: NPANDAY-180-024: resolving pom artifact: npanday.plugin:NPanday.Plugin:pom:1.2.2-incubating-SNAPSHOT
      27-ott-2010 9.56.43 npanday.PathUtil getDotNetArtifact
      AVVERTENZA:
      NPANDAY-1005-0001: Error copying dependency npanday.plugin:NPanday.Plugin:library:4b435f4d76e2f0e6:1.2.2-incubating-SNAPSHOT:runtime File C:\var\cache
      \maven\repository\npanday\plugin\NPanday.Plugin\1.2.2-incubating-20101021.032458-5\NPanday.Plugin-1.2.2-incubating-20101021.032458-5-4b435f4d76e2f0e6.
      dll does not exist
      27-ott-2010 9.56.43 npanday.dao.impl.ProjectDaoImpl storeProjectAndResolveDependencies
      INFO: NPANDAY-180018: Not found in local repository, now retrieving artifact from wagon:npanday.plugin:NPanday.Plugin:library:4b435f4d76e2f0e6:1.2.2
      incubating-SNAPSHOT, Failed Path Check = C:\Documents and Settings\pb00018.WPIT\My Documents\Development\WindowsFormsApplication3\target\NPanday.Plugi
      n.dll
      Downloading: https://samson.prov.bz/artifactory/repo//npanday/plugin/NPanday.Plugin/1.2.2-incubating-SNAPSHOT/NPanday.Plugin-1.2.2-incubating-20101021
      .032458-5-4b435f4d76e2f0e6.dll
      0b downloaded (NPanday.Plugin-1.2.2-incubating-20101021.032458-5-4b435f4d76e2f0e6.dll)
      [INFO] Unable to find resource 'npanday.plugin:NPanday.Plugin:library:4b435f4d76e2f0e6:1.2.2-incubating-SNAPSHOT' in repository egov-default (https://
      samson.prov.bz/artifactory/repo/)
      27-ott-2010 9.56.47 npanday.dao.impl.ProjectDaoImpl storeProjectAndResolveDependencies
      GRAVE: NPANDAY-180-0201: Error resolving artifact. Reason:
      org.apache.maven.artifact.resolver.ArtifactNotFoundException: Unable to download the artifact from any repository

      Try downloading the file manually from the project website.

      Then, install it using the command:
      mvn install:install-file -DgroupId=npanday.plugin -DartifactId=NPanday.Plugin -Dversion=1.2.2-incubating-20101021.032458-5 -Dclassifier=4b435f4d76
      e2f0e6 -Dpackaging=library -Dfile=/path/to/file

      Alternatively, if you host your own repository you can deploy the file there:
      mvn deploy:deploy-file -DgroupId=npanday.plugin -DartifactId=NPanday.Plugin -Dversion=1.2.2-incubating-20101021.032458-5 -Dclassifier=4b435f4d76e2
      f0e6 -Dpackaging=library -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]

      npanday.plugin:NPanday.Plugin:library:1.2.2-incubating-20101021.032458-5

      from the specified remote repositories:
      central (http://repo1.maven.org/maven2),
      egov-default (https://samson.prov.bz/artifactory/repo/)

      at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:228)
      at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:90)
      at npanday.dao.impl.ProjectDaoImpl.storeProjectAndResolveDependencies(ProjectDaoImpl.java:767)
      at npanday.dao.impl.ProjectDaoImpl.storeProjectAndResolveDependencies(ProjectDaoImpl.java:414)
      at npanday.artifact.impl.AssemblyResolverImpl.resolveTransitivelyFor(AssemblyResolverImpl.java:131)
      at npanday.artifact.impl.ArtifactInstallerImpl.resolveAndInstallNetDependenciesForProfile(ArtifactInstallerImpl.java:166)
      at npanday.plugin.resolver.NetDependencyResolverMojo.execute(NetDependencyResolverMojo.java:163)
      at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:490)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:694)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:556)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:535)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:387)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:348)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:180)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
      at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      Caused by: org.apache.maven.wagon.ResourceDoesNotExistException: Unable to download the artifact from any repository
      at org.apache.maven.artifact.manager.DefaultWagonManager.getArtifact(DefaultWagonManager.java:404)
      at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:216)
      ... 25 more
      java.io.IOException: NPANDAY-180-020: Problem in resolving artifact: Artifact = npanday.plugin:NPanday.Plugin:library:4b435f4d76e2f0e6:1.2.2-incubatin
      g-SNAPSHOT, Message = Unable to download the artifact from any repository

      Try downloading the file manually from the project website.

      Then, install it using the command:
      mvn install:install-file -DgroupId=npanday.plugin -DartifactId=NPanday.Plugin -Dversion=1.2.2-incubating-20101021.032458-5 -Dclassifier=4b435f4d76
      e2f0e6 -Dpackaging=library -Dfile=/path/to/file

      Alternatively, if you host your own repository you can deploy the file there:
      mvn deploy:deploy-file -DgroupId=npanday.plugin -DartifactId=NPanday.Plugin -Dversion=1.2.2-incubating-20101021.032458-5 -Dclassifier=4b435f4d76e2
      f0e6 -Dpackaging=library -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]

      npanday.plugin:NPanday.Plugin:library:1.2.2-incubating-20101021.032458-5

      from the specified remote repositories:
      central (http://repo1.maven.org/maven2),
      egov-default (https://samson.prov.bz/artifactory/repo/)

      at npanday.dao.impl.ProjectDaoImpl.storeProjectAndResolveDependencies(ProjectDaoImpl.java:782)
      at npanday.dao.impl.ProjectDaoImpl.storeProjectAndResolveDependencies(ProjectDaoImpl.java:414)
      at npanday.artifact.impl.AssemblyResolverImpl.resolveTransitivelyFor(AssemblyResolverImpl.java:131)
      at npanday.artifact.impl.ArtifactInstallerImpl.resolveAndInstallNetDependenciesForProfile(ArtifactInstallerImpl.java:166)
      at npanday.plugin.resolver.NetDependencyResolverMojo.execute(NetDependencyResolverMojo.java:163)
      at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:490)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:694)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:556)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:535)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:387)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:348)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:180)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
      at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] NPANDAY-180-020: Problem in resolving artifact: Artifact = npanday.plugin:NPanday.Plugin:library:4b435f4d76e2f0e6:1.2.2-incubating-SNAPSHOT, Me
      ssage = Unable to download the artifact from any repository

      Try downloading the file manually from the project website.

      Then, install it using the command:
      mvn install:install-file -DgroupId=npanday.plugin -DartifactId=NPanday.Plugin -Dversion=1.2.2-incubating-20101021.032458-5 -Dclassifier=4b435f4d76
      e2f0e6 -Dpackaging=library -Dfile=/path/to/file

      Alternatively, if you host your own repository you can deploy the file there:
      mvn deploy:deploy-file -DgroupId=npanday.plugin -DartifactId=NPanday.Plugin -Dversion=1.2.2-incubating-20101021.032458-5 -Dclassifier=4b435f4d76e2
      f0e6 -Dpackaging=library -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]

      npanday.plugin:NPanday.Plugin:library:1.2.2-incubating-20101021.032458-5

        Issue Links

          Activity

          Brett Porter added a comment -

          this seems to be a known problem with building the code with an earlier version: http://mail-archives.apache.org/mod_mbox/incubator-npanday-dev/201010.mbox/%3C87580731.2527.1288142987709.JavaMail.root@cell.g2ix.net%3E

          While that is being sorted out, can you build from source?

          Luca Di Stefano added a comment -

          yes of course!

          Adelita L. Padilla added a comment -

          Hi Luca,

          I think with the modifications done on trunk and CI, this issue no longer exists.

          So I'll be resolving this issue for now.

          Thanks!


            People

            • Assignee:
              Unassigned
              Reporter:
              Luca Di Stefano
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development