Uploaded image for project: 'Apache NiFi'
  1. Apache NiFi
  2. NIFI-9877

nifi-scripting-processors License Issue with did_you_mean-1.2.0

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Trivial
    • Resolution: Duplicate
    • 1.16.0
    • 1.17.0, 1.16.1
    • Extensions
    • None

    Description

      The nifi-scripting-processors jruby-complete 9.2.6.0 dependency is bundled with did_you_mean-1.2.0 gem, which includes the file evaluation/incorrect_words.yaml.

      This file in question has a cc-by-nc-SA license, which states cannot be used for commercial use.
      https://github.com/ruby/did_you_mean/blob/v1.2.0/evaluation/incorrect_words.yaml 

      For the releases to be compliant, could did_you_mean be upgraded to 1.2.1 or later?
      https://github.com/ruby/did_you_mean/issues/175

       Exact path found in :

      nifi-1.16.0/nifi-scripting-nar-1.16.0.nar/META-INF/bundled-dependencies/jruby-complete-9.2.6.0.jar/META-INF/jruby.home/lib/ruby/gems/shared/gems/did_you_mean-1.2.0/evaluation/incorrect_words.yaml

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              Donovan Brittney Donovan
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: