Uploaded image for project: 'Apache NiFi'
  1. Apache NiFi
  2. NIFI-6182

Update Provenance Repository to use Lucene 8.x

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.10.0
    • Component/s: Core Framework
    • Labels:
      None

      Description

      The Provenance Repository is built against a rather old version of Apache Lucene (4.x, I believe). The current version is 8.0. We should update to the latest to ensure that we are able to take advantage of all newest features and ensure that if any vulnerabilities are discovered, that they will be dealt with. Having very old dependencies generally makes it very hard to address any vulnerabilities or failures that occur.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                markap14 Mark Payne
                Reporter:
                markap14 Mark Payne
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 0.5h
                  0.5h