Uploaded image for project: 'Apache NiFi'
  1. Apache NiFi
  2. NIFI-5919

Occasionally FlowFiles appear to get "stuck" in a Load-Balanced Connection

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.0
    • Fix Version/s: 1.9.0
    • Component/s: Core Framework
    • Labels:
      None

      Description

      When a Connection is configured to Load Balance across the cluster, we have seen reports on the mailing list of FlowFiles getting "stuck". The connection shows that the data is being actively load balanced, but the FlowFiles never move. Listing or emptying the queue indicate that there are no FlowFiles. Upon restart, the FlowFile does not exist and the queue is cleared.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                markap14 Mark Payne
                Reporter:
                markap14 Mark Payne
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 0.5h
                  0.5h