Uploaded image for project: 'Apache NiFi'
  1. Apache NiFi
  2. NIFI-5032

Use explicit versions for transitive dependencies

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.6.0
    • Component/s: Tools and Build
    • Labels:
      None

      Description

      The openid-connect library oauth2-oidc-sdk contains a number of dependencies which have version ranges. These ranges can be problematic to ensuring repeatable builds in different environments. These ranges should be overridden to ensure consistent classpaths. 

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mcgilman Matt Gilman
                Reporter:
                mcgilman Matt Gilman
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: