Uploaded image for project: 'Apache NiFi'
  1. Apache NiFi
  2. NIFI-3795

nifi-assembly fails with "no formats specified" error

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.2.0
    • Fix Version/s: 1.2.0
    • Component/s: None
    • Labels:
      None

      Description

      After staging the 1.2.0 RC1 artifacts, I then downloaded the source zip from the Nexus staging repo, unzipped it and ran "mvn clean install -DskipTests" to verify that it would build. I encountered the below error:

      [ERROR] Failed to execute goal org.apache.maven.plugins:maven-assembly-plugin:2.5.2:single (make shared resource) on project nifi-assembly: No formats specified in the execution parameters or the assembly descriptor. -> [Help 1]

      After some debugging it was determined that one difference between this build and the previous build that staged the artifacts, is that this build was not within a git repo where as the other one was.

      After running git init, adding all files, and making a commit, then the build passed. Still unclear as to why being in a git repo matters here, although every NAR now tries to use the git info from the buildnumber plugin to filter into the MANIFEST files.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jameswing James Wing
                Reporter:
                bbende Bryan Bende
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: