Uploaded image for project: 'Apache NiFi'
  1. Apache NiFi
  2. NIFI-2119

Secure clustering returning bad request response

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.7.0
    • Component/s: Core Framework
    • Labels:
      None

      Description

      Cannot get a secured cluster working that worked well on 0.6.0. After upgrading now seeing the following line. It either means I upgraded incorrectly, or we're missing critical migration guidance, or we have introduced a new bug.
      2016-06-25 14:19:12,017 INFO [NiFi Web Server-23] o.a.n.w.a.c.IllegalArgumentExceptionMapper java.lang.IllegalArgumentException: User account already created CN=box1.testing.org, OU=NIFI, O=Apache-NiFi, L=Here, ST=There, C=EVERYWHERE. Returning Bad Request response.

      Speaking with Matt Gilman about this he looked into it and says
      "the socket used for cluster communications is configured with an sslContext that has client auth set to none... which seems to be why the we're not getting the NCM DN during connection
      i think the issue is this part of this commit.... https://github.com/apache/nifi/commit/7b5583f3a8c8e3f62e2985059a3466a5bb36f4e8#diff-a14f46a45c394fbd82a2b99730e04bcbR68"

        Attachments

        Issue Links

          Activity

            People

            • Assignee:
              alopresto Andy LoPresto
              Reporter:
              joewitt Joe Witt

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment