Uploaded image for project: 'Apache NiFi'
  1. Apache NiFi
  2. NIFI-1347

Use explicit version reference and fix dependency reference

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.5.0
    • Component/s: Extensions
    • Labels:
      None

      Description

      The riemann bundle had the nifi-riemann-nar referencing a dependency using maven project version shortcut rather than explicit reference. We've abolished use of this because it has been observed to cause strange multi-module or release plugin related behavior and it offers no benefit. Versions are automatically managed during the release process and using version plugins as needed so not worth the hassle. Also, the dependency section of the bundle referenced the com.aphyr client which means each sub module automatically gets that dependency. Better to switch to dependencyManagement and then explicitly pull in the needed item on the appropriate artifact.

      Finally, adjusted the formatting to be more consistent with other modules.

        Attachments

        1. 0001-NIFI-1347.patch
          12 kB
          Joe Witt

          Activity

            People

            • Assignee:
              joewitt Joe Witt
              Reporter:
              joewitt Joe Witt
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: