Uploaded image for project: 'NetBeans'
  1. NetBeans
  2. NETBEANS-877

netbeans 9.0 rc1 : cannot update plugins : java source base version 2 required

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 9.0
    • Fix Version/s: 9.0
    • Component/s: java - Source
    • Labels:
      None
    • Environment:
      openjdk version "9-Debian"
      OpenJDK Runtime Environment (build 9-Debian+0-9b181-4bpo91)
      OpenJDK 64-Bit Server VM (build 9-Debian+0-9b181-4bpo91, mixed mo

      Description

      (I) created as "blocker"  because it happens on first install and fails all plugin updates.

      installed rc1 (linux openjdk9 with the source package too - on debian 9)
      java -version
      openjdk version "9-Debian"
      OpenJDK Runtime Environment (build 9-Debian+0-9b181-4bpo91)
      OpenJDK 64-Bit Server VM (build 9-Debian+0-9b181-4bpo91, mixed mode)

      netbeans updates are available however the following error is reported.  This happened with the beta's and with jdk10 too.

      Some plugins require plugin Java Source Base to be installed.
      The plugin Java Source Base is requested in implementation version 2.
              The following plugin is affected: Java Shell Support

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              hanasaki hanasaki jiji
            • Votes:
              2 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated: