Uploaded image for project: 'NetBeans'
  1. NetBeans
  2. NETBEANS-6225

Netbeans loses almost all functionality after package update

VotersWatch issueWatchersLinkUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Invalid
    • 12.4
    • None
    • Operating System: Manjaro Linux (Qonos 21.2.0)

      JDK Version: openjdk 17.0.1

      Package Manager: Pamac 10.3.0-1 - libpamac 11.2.0

    Description

      After updating packages on Linux machine, Netbeans loses all functionality. New Java with Ant projects or files can not be created, and existing projects can not be opened. Projects that remain open can not be built or run. The navigator remains stuck on "Please wait..." and the output window stays blank. This issue occurs independently of program complexity, and projects that are as simple as "hello world" programs can not be opened or run. Projects with Maven can be created, but new files within those projects can not be created or run.

      I initially installed Netbeans and used it for several weeks without issue. I suspect that my package manager somehow messed up one of the dependencies of Netbeans, but I've been unsuccessful in finding exactly which one. I've tried reinstalling Netbeans, removing everything related to Java development from my machine, and even deleting all of my NetBeansProjects directory to resolve the problem, but nothing has been successful. I also tried installing NetBeans 12.5, but I was met with the same issue. I worry that in my attempts to solve the problem myself, I probably made the issue worse.

      Also, my apologies for the poorly made bug report. I'm very new to Jira, but I hope I can give all the information you need. It sounds likely that this might be an issue with my package manager, so I understand if there isn't much that can be done.

      Attachments

        1. IDElog
          102 kB
          Mac Coleman

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            Unassigned Unassigned
            mcole Mac Coleman
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment