Uploaded image for project: 'NetBeans'
  1. NetBeans
  2. NETBEANS-4387

Action Items reports warning erroneously

Rank to TopRank to BottomVotersWatch issueWatchersConvert to sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Invalid
    • Affects Version/s: 11.3
    • Fix Version/s: None
    • Labels:
      None
    • Environment:

      Windows 10 Pro 64
      netbeans 11.3
      Java 14.0.1
      Maven 3.5.4
      Maven compiler plugin 3.8.1

      Description

      Compiling a BOM with maven, action items are appearing such as:

      Warning Boolean.class: major version 58 is newer than 57, the highest major version supported by this compiler. It is recommended that the compiler be upgraded. EntityValidator.java C:/Users/Dan/Documents/NetBeansProjects/ZeroBudget/db/src/main/java/com/dal/zb/db/EntityValidator.java

      I have removed Java 13 from my machine, netbeans.conf references Java 14, Path references 14, project and all modules are set to source/binary 14 and to use 14 compiler.

      The references show that Java classes are version 58, but that this compilers highest major version is 57.

      I've verified that the classes built are indeed version 58.

      Find attached POM file for BOM and the module in which EnittyValidator exists.

        Attachments

        1. pom.xml
          4 kB
          Daniel Adams
        2. pom.xml
          2 kB
          Daniel Adams

          Activity

          $i18n.getText('security.level.explanation', $currentSelection) Viewable by All Users
          Cancel

            People

            • Assignee:
              Unassigned
              Reporter:
              JiroDan Daniel Adams

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment