Uploaded image for project: 'NetBeans'
  1. NetBeans
  2. NETBEANS-2339

Cannot find symbol for generated sources

Attach filesAttach ScreenshotAdd voteVotersWatch issueWatchersLinkUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    Description

      I have a Maven project that uses Hibernate's metamodel processor to generate metamodel classes used in JPA Criteria Queries. The sources are generated, and visible in the "Generated Sources (annotations)" branch in my project tree, but show-up as errors when used in the source files.

      Easy way to apply the generator in maven the way I do it:

          <properties>
              <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
              <maven.compiler.source>1.8</maven.compiler.source>
              <maven.compiler.target>1.8</maven.compiler.target>
              <maven.compiler.compilerArguments.processor>org.hibernate.jpamodelgen.JPAMetaModelEntityProcessor</maven.compiler.compilerArguments.processor>
              <maven.install.skip>true</maven.install.skip>
              <maven.deploy.skip>true</maven.deploy.skip>
              <hibernate.version>5.2.14.Final</hibernate.version>
          </properties>

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            Unassigned Unassigned
            coladict Yordan Gigov

            Dates

              Created:
              Updated:

              Slack

                Issue deployment