Uploaded image for project: 'MyFaces Core'
  1. MyFaces Core
  2. MYFACES-3927

Myfaces 2.2.4 not compatible with Google App Engine

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 2.2.4
    • Fix Version/s: 2.2.6
    • Component/s: None
    • Labels:
      None
    • Environment:
      Google App Engine for Java

      Description

      Google App Engine (GAE) for Java uses Servlet 2.5 (Jetty). Myfaces 2.2.4 starts to use Servlet 3.0 calls for http cookies, as described in the issue MYFACES-3923. It is incompatible with GAE (until GAE updated to servlet 3.0 that, for some reasons, is not happening). Can the issue be solved by introducing a context parameter to configure Myfaces 2.2.* to use servlet 2.5 or servlet 3.0?

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                lu4242 Leonardo Uribe
                Reporter:
                pauljenq Paul Jenq
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: