MyFaces Core
  1. MyFaces Core
  2. MYFACES-3540

org.apache.myfaces.HANDLE_STATE_CACHING_MECHANICS = false results in client side state saving

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Not a Problem
    • Affects Version/s: 2.1.7
    • Fix Version/s: None
    • Component/s: General
    • Labels:
      None
    • Environment:
      Richfaces 4.2.1 Final, Tomahawk20_1.1.12, Tomcat 6.0.35

      Description

      Setting the parameter org.apache.myfaces.HANDLE_STATE_CACHING_MECHANICS to false results in a blown up view state on client side.
      The content of javax.faces.ViewState is > 10 times larger.

      Comparison:
      HANDLE_STATE_CACHING_MECHANICS = true
      Request content length: 2369 bytes
      Response content length: 1849 bytes

      Same operation with HANDLE_STATE_CACHING_MECHANICS = false
      Request content length: 28095 bytes
      Response content length: 25783 bytes

      There seems to be something wrong with the state saving.

      1. web.xml
        4 kB
        Michael Heinen

        Activity

        Michael Heinen added a comment -

        web.xml with config parameters

        Leonardo Uribe added a comment -

        That param is for backward compatibility with the old behavior of StateManager in MyFaces. Maybe some change done causes the problem but it is not a big deal, because there are no known cases that requires this behavior (in theory a StateManager wrapper could rely on this behavior).

        Michael Heinen added a comment -

        It's also not a real problem for me.
        I just noticed it during testing (played around with config) and reported it therefore.
        The priority is maybe set too high therefore.

        Leonardo Uribe added a comment -

        I checked it and the problem is this param requires to set as StateManager implementation in your faces-config.xml the old org.apache.myfaces.application.jsp.JspStateManagerImpl . I just added a clarification in the javadoc / web config param documentation, warning user to set also the old JspStateManagerImpl when this param is set to false.


          People

          • Assignee:
            Leonardo Uribe
            Reporter:
            Michael Heinen
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development