MyFaces Core
  1. MyFaces Core
  2. MYFACES-3529

version 2.1.5 worked with path in resources library, version 2.1.7 doest not (only a name work) same for Composite Components in default location

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.1.7
    • Fix Version/s: None
    • Component/s: General
    • Labels:
      None

      Description

      In version 2.1.5 library resources could have bin located in cascaded sub-folders like e.g. resources/group/mylibrary and referenced in a page with: <h:graphicImage library="group/mylibrary" name="image.png">.
      This does not work in version 2.1.7 any more. There you need to put the image file in a direct sub-folder of resources.
      So the attribute 'library' is not a path but only a name.

      Same situation with location of composite components. They need to be in a direct sub-folder of resources in version 2.1.7 while in version 2.1.5 it worked with cascaded sub-folders too.

        Issue Links

          Activity

          Petra Berg created issue -
          Leonardo Uribe made changes -
          Field Original Value New Value
          Link This issue duplicates MYFACES-3454 [ MYFACES-3454 ]
          Leonardo Uribe added a comment -

          This is a duplicate of MYFACES-3454. In few words, according to JSF 2.0 spec section 2.6.1.3 "Resource Identifiers", libraryName cannot contains path separator char. So, use "group/mylibrary" as libraryName is invalid. In MYFACES-3454 it is described two workarounds to this issue.

          Leonardo Uribe made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Assignee Leonardo Uribe [ lu4242 ]
          Resolution Duplicate [ 3 ]
          Leonardo Uribe made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

            People

            • Assignee:
              Leonardo Uribe
              Reporter:
              Petra Berg
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development