Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1.5
    • Fix Version/s: 2.0.12, 2.1.6
    • Component/s: None
    • Labels:
      None
    • Environment:
      richfaces-4.1.0.Final and richfaces-4.1.1-SNAPSHOT (11.01.2012)
      myfaces-2.1.5 and myfaces-2.1.6-SNAPSHOT

      Description

      If i do sorting within richfaces extendeddatatable component a js error occurs.

      A testcase to reproduce this issue is attached.

      Steps to reproduce this issue:

      1. http://localhost:8080/jsf2testcase/extendeddatatable.jsf
      2. click 'Sort ColumnA'
      3. js-error occurs

      If you use Firefox 9 or chrome 16, everything works as expected. If you use IE8, the following js-error occurs:

      IE-8 js-error:
      Meldung: 'richfaces.utils.getCSSRule(...).style' ist Null oder kein Objekt
      Zeile: 362
      Zeichen: 17
      Code: 0
      URI: http://localhost:8080/jsf2testcase/javax.faces.resource/extendedDataTable.js.jsf;jsessionid=F4E29BC7AFDDEBB4A0395E622B5B44E7?ln=org.richfaces

      Meldung: '_mfInternal' ist Null oder kein Objekt
      Zeile: 1
      Zeichen: 99511
      Code: 0
      URI: http://localhost:8080/jsf2testcase/javax.faces.resource/jsf.js.jsf;jsessionid=F4E29BC7AFDDEBB4A0395E622B5B44E7?ln=javax.faces

      Note: This issue doesn't occur with mojarra-2.1.5
      Because of this, i think, that this is a myfaces issue and not a richfaces one.

        Activity

        Werner Punz added a comment -

        Thanks leo, this indeed was a small issue.

        Leonardo Uribe added a comment -

        found small bug on condition to check IE8 on _Dom.js

        Rene O added a comment -

        Everything is ok now.

        Werner Punz added a comment -

        The issue was a bug IE8 inherited from IE6, if an innerHTML is performed and some script tags are inside there is a chance that the markup is messed up, the script tags and other tags are lost in certain combinations.

        While we have fixed the issue for IE6 it went unnoticed that IE8 also is affected by the problem (IE9 is not). We simply activated the fixup code for ie6 also for IE7 and IE8 which resolves the problem.

        After activating the bug the problem now seems to be gone away.

        Werner Punz added a comment -

        Preliminary tests with the table/form fix for the ie swallowed script bug shows that the issue also is fixable with the workaround on IE8. So we do not have to change our eval strategy. So the entire issue is less a bug in myfaces but more a bug in IE8, but nevertheless it needs to be fixed in myfaces.

        Werner Punz added a comment -

        Ok I think I found the bug, IE8 seems to have the same script swallow bug as IE6... The problem is that the table returns a combination of script and tags which seems to swallow the script in innerHTML and some subsequent divs this later on causes problems in the init code.
        Since I have a workaround for this issue for IE6 we can apply the same workaround for ie8 as well.

        Werner Punz added a comment -

        Ok a short investigation reveales that the first error occurs here on IE9 but only in IE8 mode, the second error is not reproducable on my testsetup, I will investigate the bug further next week. It could be a combination of IE8 bug and Richfaces bug, which is triggered due to the different way we process the response compared to Mojarra, but nevertheless it needs to be fixed.

        Werner Punz added a comment -

        Ok I was working on a similar issue regarding the fileupload, it seems that I have missed one more part where the this can occur.
        I will investigate this early next week.

        Thanks for reporting the bug.


          People

          • Assignee:
            Werner Punz
            Reporter:
            Rene O
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development