MyFaces Core
  1. MyFaces Core
  2. MYFACES-3391

jsf.js: Lifecycle, success should not be called if an error is raised

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.10-SNAPSHOT, 2.1.4-SNAPSHOT
    • Fix Version/s: 2.0.10, 2.1.4
    • Component/s: None
    • Labels:
      None

      Description

      We have a small lifecycle problem. In case of an error the the success event should not be called anymore. We currently call it.

        Activity

        Werner Punz added a comment -

        ok is fixed, a regression testcase has been added to my integration testsuite to check exactly this behavior. The testcase now is unter test1protocol.jsf.

        Werner Punz added a comment -

        Ok seems to be valid after a second check

        Werner Punz added a comment -

        Seems to be the expected behavior


          People

          • Assignee:
            Unassigned
            Reporter:
            Werner Punz
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development