MyFaces Core
  1. MyFaces Core
  2. MYFACES-3302

View with viewParameter remove backing-beans from the context in Restore-View-Phase when setting PROJECT_STAGE to Development

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      Tested on Jetty and IBM WebSphere 8
      CODI-Extension

      Description

      I use the ViewAccessScope from CODI.
      If I create a bean with viewAccessScope and link from a view (where the bean is called) to another view (where the bean is accessed too) and then go back to the original view, I expect, that the same instance of the bean is used. But at the time I go back to the original view in the Restore-View-Phase the instance of the bean is destroyed and a new one is created.

      This behaviour only happen if I use the PROJECT_STAGE=Development AND implement a viewParameter to the view. So I think, that in Development-Stage the <metadata>-Tag or the <viewParameter>-Tag do something that brings the BeanManager to handle the beans in abnormal way.

      There is a sample project at https://bitbucket.org/os890/myfaces-mailing-list/src/56d0ef922d12

        Issue Links

          Activity

          Steven Rudolf created issue -
          Steven Rudolf made changes -
          Field Original Value New Value
          Link This issue is cloned as EXTCDI-222 [ EXTCDI-222 ]
          Leonardo Uribe made changes -
          Link This issue duplicates MYFACES-3187 [ MYFACES-3187 ]
          Leonardo Uribe added a comment -

          This is a duplicate of MYFACES-3187, which was fixed on 2.0.8/2.1.2

          Leonardo Uribe made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Assignee Leonardo Uribe [ lu4242 ]
          Resolution Duplicate [ 3 ]

            People

            • Assignee:
              Leonardo Uribe
              Reporter:
              Steven Rudolf
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development