MyFaces Core
  1. MyFaces Core
  2. MYFACES-3293

REGRESSION: 2.0.5->2.0.6: RendererUtils.renderChild no longer checks isRendered

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.6, 2.0.7
    • Fix Version/s: 2.0.8, 2.1.2
    • Component/s: None
    • Labels:
      None

      Description

      Hi guys,

      Thanks for all the work you do on MyFaces. It is such a robust JSF implementation.

      There appears to have been a regression between 2.0.5 and 2.0.6/2.0.7? Specifically, RendererUtils.renderChild no longer does an 'upfront' check of whether a UIComponent is rendered or not. This logic appears flawed if the UIComponent does not render its own children (the default in Renderer.getRendersChildren)?

      First, encodeBegin/encodeEnd for the UIComponent will skip (the default in UIComponentBase.encodeBegin). But encodeChildren for the UIComponent will not get called (because getRendersChildren is false), so the UIComponent has no opportunity to prevent rendering of its children. Instead RendererUtils will invoke encodeBegin/encodeEnd on each child directly. So if a rendered component is nested inside a non-rendered component, it will still appear.

      Surely there is an implication that even if I elect not to render my own children (i.e. I let JSF handle it), they should not get rendered if I myself am not rendered?

      I enclose a small project that demonstrates the issue. Hopefully it is sufficient to debug. If not I can try and untangle it from Metawidget.

      1. addressbook-faces2.war
        5.41 MB
        Kennard Consulting
      2. addressbook-faces2.war
        6.07 MB
        Kennard Consulting
      3. addressbook-faces2-src.zip
        35 kB
        Kennard Consulting

        Issue Links

          Activity

          Kennard Consulting added a comment -

          Agreed.

          Leonardo Uribe added a comment -

          This one and MYFACES-3294 are different issues. Checking this one, it was fixed on MYFACES-3126, which was included on 2.0.8/2.1.2. I'll close this one as fixed on 2.0.8/2.1.2

          Kennard Consulting added a comment -

          Okay great. Now opened as MYFACES-3294.

          Martin Kočí added a comment -

          Hi, this is another problem, probably related to state saving, please create new issue for that, there were changes in state saving (master bug MYFACES-3117)

          Kennard Consulting added a comment -

          Test case. See steps above. My hunch would be this is related to facets getting lost in state saving? My renderer uses facets to determine the CSS styles. But this behaviour is new to 2.0.8.

          Kennard Consulting added a comment -

          Martin,

          Thanks for your fast response! It does indeed sound like the same bug, and it seems to fix the problem.

          I say 'seems to' because something very strange happens instead! Please see attached sample project. To reproduce:

          1. Deploy the WAR
          2. Click 'Add Personal Contact'
          3. Click 'Save' (without entering any values, therefore getting a validation error)
          4. Upon validation error, note CSS styles have disappeared from many parts of the XHTML! In particular around the table
          5. Switch the 2.0.8 JARs for 2.0.7, and it works fine

          Please confirm if you can reproduce, and whether I should open a new JIRA or whether it is related to the previous fix?

          Regards,

          Richard.

          Martin Kočí added a comment -

          Hi,
          this was bug MYFACES-3126 I think, it should be fixed in 2.0.8 (even for the rendered="#

          {component}

          " case). Can you try 2.0.8 (just released), please?

          Kennard Consulting added a comment -

          Test WAR.

          Deploy the WAR as normal. Note the text box appears (this is incorrect).

          Edit the WEB-INF/lib folder and rename the supplied old version of 2.0.5 to be .jar (and remove the 2.0.6 version). Re-run and no text box appears (this is correct).


            People

            • Assignee:
              Leonardo Uribe
              Reporter:
              Kennard Consulting
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development