MyFaces Core
  1. MyFaces Core
  2. MYFACES-3187

DebugPhaseListener shouldn't be active by default

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.7, 2.1.1
    • Fix Version/s: 2.0.8, 2.1.2
    • Component/s: JSR-314
    • Labels:
      None

      Description

      this phase-listener leads to a different behaviour in project-stage development -> it shouldn't be active by default

        Issue Links

          Activity

          Martin Kočí added a comment -

          Is MYFACES-3033 same problem?

          Leonardo Uribe added a comment -

          Probably this is a side effect caused because DebugPhaseListener evaluates EL expressions that activates session or makes some scopes behave different. Is it the case Gerhard?

          Gerhard Petracek added a comment - - edited

          there are several possible problems caused by this phase-listener. it depends on the additional libs and/or your pages.

          @leo:
          yes that's one of the problems.

          however, in any case the debug project-stage shouldn't change the behaviour.
          e.g. if users set breakpoints to check if a specific getter gets called, they shouldn't have to be aware that something like our listener calls it.
          they might wonder why the value isn't used even though the getter gets called during the request.

          Leonardo Uribe added a comment -

          I remember a discussion with Jakob about this specific problem, and specially on make DebugPhaseListener enabled by default. It is true that DebugPhaseListener does not cause any problems in most cases, but the fact that could break orchestra 'access' scope and other CODI scopes, makes necessary disable this by default. There is no viable solution to enable it by default and keep code working in all situations, just because there is no way to detect when it is valid or not evaluate the expressions. This problem is to annoying to let it pass.


            People

            • Assignee:
              Leonardo Uribe
              Reporter:
              Gerhard Petracek
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development