MyFaces Core
  1. MyFaces Core
  2. MYFACES-3146

ui:fragment (ComponentRef) is responsible for rendering its child components

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: 2.1.0-SNAPSHOT
    • Fix Version/s: 2.0.8, 2.1.2
    • Component/s: None
    • Labels:
      None
    • Environment:
      myfaces core trunk

      Description

      JSF 2.0 rev A spec says that ui:fragment has rendered property: If this attribute's value is "false" or the value is an EL expression that evaluates to "false", the fragment is not rendered in the page.

      Because ui:fragment is component-only (no renderer) it should returns from getRendersChildren() true to satisfy specified behaviour.

      http://java.net/jira/browse/JAVASERVERFACES_SPEC_PUBLIC-661

      1. MYFACES-3146.patch
        0.5 kB
        Martin Kočí

        Issue Links

          Activity

          Leonardo Uribe added a comment -

          This issue needs to be fixed on next release.

          Leonardo Uribe added a comment -

          This issue is a duplicate of MYFACES-3293. It seems it is better described there and this is just a particular use case of that one, so I close this as duplicate

          Leonardo Uribe added a comment -

          Checking this one it seems it was fixed on MYFACES-3126, so 2.0.8/2.1.2 has the fix.


            People

            • Assignee:
              Martin Kočí
              Reporter:
              Martin Kočí
            • Votes:
              2 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development