MyFaces Core
  1. MyFaces Core
  2. MYFACES-3133

"cc" attribute cannot be resolved when composite component is used inside a datatable

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0.2
    • Fix Version/s: 2.0.7, 2.1.1
    • Component/s: None
    • Labels:
      None

      Description

      When a composite component is used inside a datatable, the resolving of the general "cc"-attribute does not work consistently. For value bindings (with e.g. inputText) everything seems to be fine, but when used inside an "actionListener"-attribute or an "action"-attribute (with e.g. commandButton) the resolvement of "cc" fails. I've isolated the problem to the method "CompositeComponentELUtils.getCompositeComponentBasedOnLocation(..)" which checks if the parent component in the component stack is a "composite component". The "HtmlDataTable" element is not recognized as such.

      1. testproject.zip
        2.67 MB
        Michael Wohlfart

        Issue Links

          Activity

          Michael Wohlfart created issue -
          Michael Wohlfart added a comment - - edited

          To reproduce the bug, deploy the dynamic webproject to your favourite container, call "<containerlocation>/testproject/test.jsf" in your favourite browser and push the button...

          Michael Wohlfart made changes -
          Field Original Value New Value
          Attachment testproject.zip [ 12478590 ]
          Michael Wohlfart added a comment -

          I haven't checked if the problem persists in newer versions than 2.0.2 yet.. will do when there is time...

          Jakob Korherr made changes -
          Assignee Jakob Korherr [ jakobkorherr ]
          Jakob Korherr added a comment -

          Hi Michael,

          Thx for the bug report.

          Since I implemented the whole #

          {cc}

          handling, I assigned the issue to myself. I will take a look at it later today or tomorrow.

          Regards,
          Jakob

          Jakob Korherr made changes -
          Fix Version/s 2.0.6-SNAPSHOT [ 12316347 ]
          Jakob Korherr made changes -
          Fix Version/s 2.0.6-SNAPSHOT [ 12316347 ]
          Leonardo Uribe made changes -
          Link This issue duplicates MYFACES-3165 [ MYFACES-3165 ]
          Leonardo Uribe added a comment -

          This is a duplicate of MYFACES-3165, so I'll close this one as duplicated

          Leonardo Uribe made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Assignee Jakob Korherr [ jakobkorherr ] Leonardo Uribe [ lu4242 ]
          Fix Version/s 2.1.1 [ 12316463 ]
          Fix Version/s 2.0.7 [ 12316465 ]
          Resolution Duplicate [ 3 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          37d 8h 1m 1 Leonardo Uribe 15/Jun/11 21:36

            People

            • Assignee:
              Leonardo Uribe
              Reporter:
              Michael Wohlfart
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development