MyFaces Core
  1. MyFaces Core
  2. MYFACES-3131

jsf.js:tables not rendering after ajax call in internet explorer 6

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.5
    • Fix Version/s: 2.0.6
    • Component/s: None
    • Labels:
      None
    • Environment:
      Tomcat 6 / Myfaces 2.0.5 and Richfaces 4.0.0.Final
      Internet Explorer 6 as client

      Description

      objects that start with <table> disappear when they are selected for render during an ajax call.
      I debugged the problem and found it occurs in the _outerHTMLNonCompliant function. When tagName is "table", _buildTableNodes is called (it really shouldn't be called in this case).
      In _buildTableNodes, dummyPlaceHolder.innerHTML is set to "<table><table>STUFF</table></table>".
      ie6 changes this to "<table><tbody></tbody><table>STUFF</table></table>" so evalNodes is set to the empty tbody and thus the table sent back from the server is lost.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        2d 23h 1m 1 Werner Punz 09/May/11 21:02
        Resolved Resolved Closed Closed
        14d 17h 43m 1 Leonardo Uribe 24/May/11 14:46
        Leonardo Uribe made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Leonardo Uribe made changes -
        Fix Version/s 2.0.6 [ 12316397 ]
        Fix Version/s 2.1.0-SNAPSHOT [ 12316325 ]
        Fix Version/s 2.0.6-SNAPSHOT [ 12316347 ]
        James G added a comment -

        Thanks for fixing this!!

        Werner Punz made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 2.0.6-SNAPSHOT [ 12316347 ]
        Fix Version/s 2.1.0-SNAPSHOT [ 12316325 ]
        Resolution Fixed [ 1 ]
        Werner Punz added a comment -

        the issue is fixed, i also ran extensive testing for subtable replacements to make sure that the subtable replacement code now is waterproof

        Werner Punz added a comment -

        Ok I will take care of this bug in the next days, in the meanwhile as a short workaround wrap the table into a panelGroup or another element and put this element on render, this should bypass the issue.
        This is a nasty bug, thanks for reporting it, I will take care that the bug wont be in the next myfaces release.

        Werner Punz made changes -
        Field Original Value New Value
        Summary tables not rendering after ajax call in internet explorer 6 jsf.js:tables not rendering after ajax call in internet explorer 6
        James G created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            James G
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development