MyFaces Core
  1. MyFaces Core
  2. MYFACES-3047

Component resources disappear after page reload

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.4
    • Fix Version/s: 2.0.5
    • Component/s: JSR-314
    • Labels:
      None

      Description

      Run attached example and click command link. Component CSS is not added to the page after that.

      1. jsf2test.zip
        5 kB
        Nick Belaevski

        Activity

        Nick Belaevski created issue -
        Nick Belaevski made changes -
        Field Original Value New Value
        Attachment jsf2test.zip [ 12471316 ]
        Nick Belaevski added a comment -

        Reproducible when partial state saving is off.

        Leonardo Uribe added a comment -

        Yes, I checked it and the problem is the component resource facets are marked as transient. Long time ago it was discussed on jsr-314-open list to mark them, but do that breaks ResourceDependency, because those resources added to the view are not restored.

        I tried other altenatives, but after thinking a lot it is better to do not mark them and instead mark all resources added as transient according to the case.

        Leonardo Uribe made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Leonardo Uribe [ lu4242 ]
        Fix Version/s 2.0.5-SNAPSHOT [ 12316168 ]
        Resolution Fixed [ 1 ]
        Leonardo Uribe made changes -
        Fix Version/s 2.0.5 [ 12316346 ]
        Fix Version/s 2.0.5-SNAPSHOT [ 12316168 ]
        Leonardo Uribe made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        7h 24m 1 Leonardo Uribe 18/Feb/11 03:05
        Resolved Resolved Closed Closed
        45d 18h 39m 1 Leonardo Uribe 04/Apr/11 22:45

          People

          • Assignee:
            Leonardo Uribe
            Reporter:
            Nick Belaevski
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development