Uploaded image for project: 'MyFaces Core'
  1. MyFaces Core
  2. MYFACES-2652

Update of some plugins in myfaces master pom makes myfaces-impl site fail

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-beta-3
    • Fix Version/s: None
    • Component/s: build process
    • Labels:
      None

      Description

      When it was released myfaces master pom v7, some dependencies were updated, specially maven site plugin and maven surefire report.

      Use the newer versions usually causes a lot of problems, specifically with myfaces-impl. It is very important before update this dependencies check if everything runs fine, because it is common have this kind of problems and it takes a lot of time and effort find and solve them.

      That's the reason why update to latest maven version is not a good idea (I'm still using 2.0.10 at april 2010). It seems we have to wait a little bit more time to see this kind of problems solved.

      The solution is update myfaces core pom.xml to use the older versions instead.

      <plugin>
      <artifactId>maven-site-plugin</artifactId>
      <version>2.0-beta-6</version>
      </plugin>
      <plugin>
      <artifactId>maven-surefire-plugin</artifactId>
      <version>2.3.1</version>
      </plugin>
      <plugin>
      <artifactId>maven-surefire-report-plugin</artifactId>
      <version>2.3.1</version>
      </plugin>

        Attachments

          Activity

            People

            • Assignee:
              lu4242 Leonardo Uribe
              Reporter:
              lu4242 Leonardo Uribe
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: