MyFaces Core
  1. MyFaces Core
  2. MYFACES-2370

'invokeOnComponent' method in UIData does not properly process <h:column> header/footer facets

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.7
    • Fix Version/s: 1.2.8
    • Component/s: General
    • Labels:
      None

      Description

      A bug that was originally reported to the RichFaces project here (includes simple test case)...

      https://jira.jboss.org/jira/browse/RF-7700

      ...was identifed by the RichFaces team as being caused by failure to process <h:column> header/footer facets in 'invokeOnComponent'. The RichFaces team reported this to the Mojarra guys...

      https://javaserverfaces.dev.java.net/issues/show_bug.cgi?id=1308

      ...who fixed it in their implementation (as of 1.2_14)

      I then put together a MyFaces version of the same test case (attached as suggestionMyFaces.zip)...

      https://jira.jboss.org/jira/browse/RF-7700

      ...and it appears MyFaces (as of 1.2.7) has the same bug?

      1. uidata.patch
        7 kB
        Jakob Korherr

        Activity

        Kennard Consulting created issue -
        Leonardo Uribe added a comment -

        It is obvious that MyFaces has the same bug, because it is a problem in the definition of the algorithm of UIData.invokeOnComponent. Note this method definition is part of the spec, but theory, if ri change this behavior, we could do the same. The only problem is if solve this one makes fail the TCK test related to this method, so if we solve this one and some problem happens on next release, we could skip this one.

        Jakob Korherr added a comment -

        Here is my patch for this issue, including a test case, in which invokeOnComponent looks for a Facet of a h:column child of UIData.

        I also tested suggestionMyFaces.zip with my implementation and it worked!

        Jakob Korherr made changes -
        Field Original Value New Value
        Attachment uidata.patch [ 12421626 ]
        Jakob Korherr made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Leonardo Uribe added a comment -

        Thanks to Jakob Korherr for provide this patch

        Leonardo Uribe made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Assignee Leonardo Uribe [ lu4242 ]
        Fix Version/s 1.2.8-SNAPSHOT [ 12314014 ]
        Resolution Fixed [ 1 ]
        Kennard Consulting added a comment -

        Terrific. Thanks for the quick turnaround guys. Look forward to trying it.

        Leonardo Uribe made changes -
        Fix Version/s 1.2.8 [ 12314390 ]
        Fix Version/s 1.2.8-SNAPSHOT [ 12314014 ]
        Leonardo Uribe made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Patch Available Patch Available
        12d 14h 21m 1 Jakob Korherr 08/Oct/09 14:35
        Patch Available Patch Available Resolved Resolved
        8h 24m 1 Leonardo Uribe 08/Oct/09 23:00
        Resolved Resolved Closed Closed
        39d 5h 12m 1 Leonardo Uribe 17/Nov/09 03:12

          People

          • Assignee:
            Leonardo Uribe
            Reporter:
            Kennard Consulting
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development