MyFaces Core
  1. MyFaces Core
  2. MYFACES-1966

facet tag is in both myfaces_core.tld and myfaces_html.tld

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.2.5-SNAPSHOT
    • Fix Version/s: 1.2.5
    • Component/s: JSR-252
    • Labels:
      None
    • Environment:
      tomcat-6.0.16
      java 1.6
      MyFaces 1.2.5-SNAPSHOT

      Description

      The following jsf code snippet works in MyFaces 1.2.5-SNAPSHOT:

      <%@ taglib uri="http://java.sun.com/jsf/core" prefix="f" %>
      <%@ taglib uri="http://java.sun.com/jsf/html" prefix="h" %>

      <html>
      <body>

      <f:view>
      <h:form>
      <h:panelGrid columns="2" rules="groups" title="Facet Tag Demo">
      <f:facet name="header">
      <h:outputText value="asdf"/>
      </f:facet>
      <h:outputText value="asdf"/>
      </h:panelGrid>

      <h:panelGrid columns="2" rules="groups" title="Facet Tag Demo">
      <h:facet name="header">
      <h:outputText value="asdf"/>
      </h:facet>
      <h:outputText value="asdf"/>
      </h:panelGrid>
      </h:form>
      </f:view>

      </body>
      </html>

      If you run this in MyFaces 1.2.4, you will get:
      JasperException thrown. No tag "facet" defined in tag library imported with prefix "h"

      The facet tag seems to have been added in myfaces_html.tld in MyFaces 1.2.5. I think this tag should only be declared in myfaces_core.tld.

        Activity

        Leonardo Uribe added a comment -


        The definition should be removed from myfaces_html.tld. The problem is on the template definition (src/main/resources/META-INF/myfaces_html.vm)

        Leonardo Uribe added a comment -

        Thanks to Paul Rivera for help us find this bug


          People

          • Assignee:
            Leonardo Uribe
            Reporter:
            Paul Rivera
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development