Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.2.0, 1.2.2, 1.2.3, 1.2.4-SNAPSHOT
    • Fix Version/s: 1.2.4
    • Component/s: JSR-252
    • Labels:
      None

      Description

      events should be transient.
      (there is no need to save events in the state)

        Activity

        Gerhard Petracek created issue -
        Leonardo Uribe added a comment -

        I complete agree. This is an old myfaces-faces-plugin bug. Maybe MYFACES-1894 it is related to this, since I have checked the code using white box model and compare with 1.1 implementation, and everything is ok. (The only difference between 1.1 and 1.2 is that the state of events is saved and restored on 1.2).

        I'll correct saveState and restoreState methods if no objections and I'll close both issues (MYFACES-1894 as duplicated and this as fixed).

        Leonardo Uribe made changes -
        Field Original Value New Value
        Assignee Leonardo Uribe [ lu4242 ]
        Gerhard Petracek added a comment -

        MYFACES-1894 is similar, but not the same.
        (there are two different places to solve the issues -> i suggest to keep these issues separated)

        MYFACES-1894: "violates the specification"
        MYFACES-1895: "doesn't make sense"

        Leonardo Uribe added a comment -

        Ok, the only thing left is know how test this part of the spec. I'll close this issue remove the save and restore state code and then try to reproduce MYFACES-1894.

        Leonardo Uribe made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Fix Version/s 1.2.4-SNAPSHOT [ 12313145 ]
        Resolution Fixed [ 1 ]
        Leonardo Uribe made changes -
        Fix Version/s 1.2.4 [ 12313378 ]
        Fix Version/s 1.2.4-SNAPSHOT [ 12313145 ]

          People

          • Assignee:
            Leonardo Uribe
            Reporter:
            Gerhard Petracek
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development