MyFaces Core
  1. MyFaces Core
  2. MYFACES-1735

Myfaces 1.2 should provide local copies of web-facesconfig_1_x.dtd

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.0
    • Fix Version/s: 1.2.2
    • Component/s: None
    • Labels:
      None
    • Environment:
      using tomahawk 1.1.6

      Description

      Situation: Tomahawk 1.1.6 is used in a myfaces 1.2.0 application. The computer where the application is run on is not connected to the internet.

      Problem: Myfaces refuses to start.

      Expected behaviour: Myfaces should start.

      Analysis: When debugging, the error is that myfaces cannot resolve the dtd declaration in tomahawk's faces-config.xml file. I do not think this is tomahawk's problem, because tomahawk wants to be myfaces-1.1 compatible. Myfaces should provide the web-facesconfig_1_0.dtd and web-facesconfig_1_1.dtd in its jar.

      In a short glance at the code in org.apache.myfaces.config.impl.FacesConfigEntityResolver , it might seem that these resources are still provided:
      public InputSource resolveEntity(...)
      {
      InputStream stream;
      if (systemId.equals(FACES_CONFIG_1_0_DTD_SYSTEM_ID))

      { stream = ClassUtils.getResourceAsStream(FACES_CONFIG_1_0_DTD_RESOURCE); }

      else if (systemId.equals(FACES_CONFIG_1_1_DTD_SYSTEM_ID))

      { stream = ClassUtils.getResourceAsStream(FACES_CONFIG_1_1_DTD_RESOURCE); }

      ....
      }
      However, the referenced resources (web-facesconfig_1_0.dtd and web-facesconfig_1_1.dtd in the org.apache.myfaces.resource package) are not packaged in any myfaces 1.2 jar. They used to be present in myfaces-impl-1.1.x.jar

      Proposed Resolution: provide web-facesconfig_1_0.dtd and web-facesconfig_1_1.dtd in the org.apache.myfaces.resource package in myfaces-impl-1.2.x.jar

        Activity

        Thomas Fox created issue -
        Thomas Fox made changes -
        Field Original Value New Value
        Status Open [ 1 ] Patch Available [ 10002 ]
        Thomas Fox added a comment -

        Set on "patch provided" because the necessary files are still in the myfaces repository

        Martin Marinschek added a comment -

        Hi Thomas,

        thanks for looking at this - should be fixed now.

        regards,

        Martin

        Martin Marinschek made changes -
        Assignee Martin Marinschek [ mmarinschek ]
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Fix Version/s 1.2.1-SNAPSHOT [ 12312571 ]
        Resolution Fixed [ 1 ]
        Matt Raible added a comment -

        Any chance of getting 1.2.1 released this week to get this fix?

        Leonardo Uribe made changes -
        Fix Version/s 1.2.1 [ 12312895 ]
        Fix Version/s 1.2.1-SNAPSHOT [ 12312571 ]
        Leonardo Uribe made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Leonardo Uribe made changes -
        Fix Version/s 1.2.2 [ 12312932 ]
        Fix Version/s 1.2.1 [ 12312895 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Patch Available Patch Available
        23s 1 Thomas Fox 27/Sep/07 15:10
        Patch Available Patch Available Resolved Resolved
        17h 24m 1 Martin Marinschek 28/Sep/07 08:34
        Resolved Resolved Closed Closed
        82d 11h 52m 1 Leonardo Uribe 19/Dec/07 19:27

          People

          • Assignee:
            Martin Marinschek
            Reporter:
            Thomas Fox
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development