MyFaces Core
  1. MyFaces Core
  2. MYFACES-1504

oamSetHiddenInput function missing if ...

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.1.5-SNAPSHOT
    • Fix Version/s: 1.1.6
    • Component/s: None
    • Labels:
      None
    • Environment:
      latest myfaces svn head

      Description

      a) ... there is only a commandButton on the form (not commandLinks)
      ... which is not necessarily a problem as normally such a form do not require these functions, BUT when you have enabled the auto_scroll feature things getting worse. Then something like
      oamSetHiddenInput('_idJsp29','autoScroll',getScrolling())
      will be rendered and then the oamSetHiddenInput function is missing.

      b) ... you are using the adf form
      in HtmlLinkRendererBase you'll see that renderFormSubmitScriptIfNecessary will not be called if the link is used within an adf form, then again the autoScroll feature is broken and a javascript error will be shown.

      Would be great if someone else has some time to fix it.

        Issue Links

          Activity

          Hide
          Leonardo Uribe added a comment -

          fixed at revision 633078

          Show
          Leonardo Uribe added a comment - fixed at revision 633078
          Hide
          Leonardo Uribe added a comment -

          Trinidad override HtmlCommandButton and HtmlCommandLink, so the solution for this on trinidad should be a separate issue

          Show
          Leonardo Uribe added a comment - Trinidad override HtmlCommandButton and HtmlCommandLink, so the solution for this on trinidad should be a separate issue
          Hide
          Sandra Martín added a comment - - edited

          where is the patch file?? Because in 1.1.5 this error already ocurrs really. Thanks.

          Show
          Sandra Martín added a comment - - edited where is the patch file?? Because in 1.1.5 this error already ocurrs really. Thanks.
          Hide
          Pawel Czerwinski added a comment -

          Can sombody tell what kind of patch is supposedly available? In 1.1.5 the error still remains.

          Show
          Pawel Czerwinski added a comment - Can sombody tell what kind of patch is supposedly available? In 1.1.5 the error still remains.

            People

            • Assignee:
              Leonardo Uribe
              Reporter:
              Mario Ivankovits
            • Votes:
              9 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development