MyFaces Core
  1. MyFaces Core
  2. MYFACES-1376

getScrolling is not defined in simple tree2 example

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.1.4-SNAPSHOT
    • Fix Version/s: 1.1.4
    • Component/s: General
    • Labels:
      None

      Description

      tree2NiceWrap.jsf throws a javascript error when you try to expand the node

        Activity

        Wendy Smoak added a comment -

        Matthias reverted part of r421297, here:

        http://svn.apache.org/viewvc?rev=428629&view=rev (shared 2.0.4 trunk)
        http://svn.apache.org/viewvc?rev=428630&view=rev (shared 2.0.3 branch)

        myfaces/shared/trunk/core/src/main/java/org/apache/myfaces/shared/renderkit/html/util/JavascriptUtils.java

        • private static final String AUTO_SCROLL_PARAM = "org_apache_myfaces_autoScroll";
        • private static final String AUTO_SCROLL_FUNCTION = "org_apache_myfaces_getScrolling";
          + private static final String AUTO_SCROLL_PARAM = "autoScroll";
          + private static final String AUTO_SCROLL_FUNCTION = "getScrolling";
        Wendy Smoak added a comment -

        On 02-Aug-2006, Matthias wrote:
        > FIXED IN BRANCH

        URL: http://svn.apache.org/viewvc?rev=428231&view=rev
        Log: fixed MYFACES-1376 by moving to commits from "svn commit: r421297" to branch

        URL: http://svn.apache.org/viewvc?rev=428230&view=rev
        Log: fixed MYFACES-1376 by moving to commits from "svn commit: r421297" to branch

        ... and r421297 is:
        Author: mmarinschek
        Date: Wed Jul 12 08:54:40 2006
        New Revision: 421297

        URL: http://svn.apache.org/viewvc?rev=421297&view=rev
        Log:
        made calling of several javascript functions dependent on if they are actually present. Added source section to the poms. Default message now also prints the message of the causes of an exception.

        Matthias Weßendorf added a comment -

        FIXED IN BRANCH

        Dennis Byrne added a comment -

        There were a ton of users on the users list who had the problem but nobody could trace it down. I was one of the folks who couldn't reproduce it. A few weeks later I had the problem on a few pages of my app. I didn't spend much time on it, but for some reason I could fix it by adjusting position of the following element ...

        <jsp:scriptlet>response.setContentType("text/html; charset=utf-8");</jsp:scriptlet>

        very weird

        sean schofield added a comment -

        Apparently Michael Hartman marked this as patch available but I don't see one. Changing status back to "Open."

        sean schofield added a comment -

        schedule1.jsf component is also experiencing this problem when you try to advance the calendar


          People

          • Assignee:
            Matthias Weßendorf
            Reporter:
            sean schofield
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development