Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      Weblogic 8.1 SP4 myfaces 1.1.1

      Description

      When used with el <f: convertDateTime > does not seem to be able to resolve the EL.
      <f:convertDateTime type="date" dateStyle="#

      {attr.patternStyle}

      " pattern="#

      {attr.patternFormat}

      " />

      Typically parttern in ConvertDateTime when you debug the code is null. Yet a system.out displays the right pattern.
      Beacsuse the pattern cannot be resolved a convertion error is thrown. When the value of pattern is change to be a static string line "dd-MM-yyyy", everything works fine.

      In the case above attr is the Object in the current row of a <x:dataTable>

        Issue Links

          Activity

          Pat McCabe added a comment -

          Any progress on this issue ?? I can't set the timezone properly at all.

          e.g. using MyFaces 1.1.5 SNAPSHOT
          <h:outputText value="#

          {listingBean.cl.dateSubmitted.time}

          ">
          <t:convertDateTime timeZone="#

          {listingBean.cl.timeZone}

          " type="both" dateStyle="short" timeStyle="short" />
          </h:outputText>

          I tried using both a TimeZone object, and then the string ID of the timezone. Both cases resulted in a null pointer exception.

          Caused by: java.lang.NullPointerException
          at org.apache.myfaces.shared_impl.taglib.core.ConvertDateTimeTagBase.setConverterTimeZone(ConvertDateTimeTagBase.java:184)
          at org.apache.myfaces.shared_impl.taglib.core.ConvertDateTimeTagBase.createConverter(ConvertDateTimeTagBase.java:85)
          at javax.faces.webapp.ConverterTag.doStartTag(ConverterTag.java:63)
          at org.apache.jsp.view.CategoryList_jsp._jspx_meth_f_convertDateTime_0(CategoryList_jsp.java:1236)
          at org.apache.jsp.view.CategoryList_jsp._jspx_meth_h_outputText_11(CategoryList_jsp.java:1211)
          at org.apache.jsp.view.CategoryList_jsp._jspx_meth_h_column_4(CategoryList_jsp.java:1129)
          at org.apache.jsp.view.CategoryList_jsp._jspx_meth_t_dataTable_1(CategoryList_jsp.java:648)
          at org.apache.jsp.view.CategoryList_jsp._jspx_meth_h_form_0(CategoryList_jsp.java:199)
          at org.apache.jsp.view.CategoryList_jsp._jspx_meth_f_view_0(CategoryList_jsp.java:151)
          at org.apache.jsp.view.CategoryList_jsp._jspService(CategoryList_jsp.java:115)
          at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
          at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
          at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:332)
          at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:314)
          at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:264)
          at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

          Leonardo Uribe added a comment -

          This issue will be closed as duplicate. A solution for this one was committed on MFCOMMONS-12


            People

            • Assignee:
              Leonardo Uribe
              Reporter:
              Raphael A BEREHOUDOUGOU
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development