MyFaces Core
  1. MyFaces Core
  2. MYFACES-1164

Cannot forward after response has been committed

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.1.2-SNAPSHOT, 1.1.3
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      winxp2,jboss 4.0.4RC1

      Description

      I used Myfaces Core 1.1.2 to test the "java.lang.IllegalStateException:
      Cannot forward after response has been committed" issue,Now found it:
      If redirect in Java back form bean,has no problem.
      But if using redirect in filter class, the problem is still exist.
      I knowned the two test-cases can pass for Sun RI.

        Activity

        Jeremy Green added a comment -

        See also MYFACES-612.

        Thomas Andraschko added a comment -

        Please check our issue closing policy: http://myfaces.apache.org/wiki/core/committer-and-pmc-guide/myfaces-project-management.html
        If the is issue is still important for you, please reopen and attach a patch.


          People

          • Assignee:
            Unassigned
            Reporter:
            forsoft
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development