Uploaded image for project: 'Maven WAR Plugin'
  1. Maven WAR Plugin
  2. MWAR-82

setting archiveClasses to true create the jar in WEB-INF/lib but does not remove WEB-INF/classes

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      This bug has been explained on the maven users mailing list:

      Hi Sebastien
      It seems to be a bug.
      In the code [1] we have :
      if ( archiveClasses )

      { createJarArchive( libDirectory ); }

      else

      { copyDirectoryStructureIfModified( classesDirectory, webappClassesDirectory ); }

      The content of the classes directory is never removed (neither in createJarArchive nor somewhere else).

      Can you create an issue please ?

      Thx

      Arnaud

      [1]
      http://svn.apache.org/viewvc/maven/plugins/trunk/maven-war-plugin/src/main/java/org/apache/maven/plugin/war/AbstractWarMojo.java?revision=471624

      Sebastien Brunot wrote:
      >
      > Hi all,
      >
      > i've got a war project which pom build section contains the following
      > statements:
      >
      > <!-- Package webapp classes into a jar instead of under
      > WEB-INF/classes -->
      > <plugin>
      > <groupId>org.apache.maven.plugins</groupId>
      > <artifactId>maven-war-plugin</artifactId>
      > <executions>
      > <execution>
      > <goals>
      > <goal>war</goal>
      > </goals>
      > <configuration>
      > <archiveClasses>true</archiveClasses>
      > </configuration>
      > </execution>
      > </executions>
      > </plugin>
      >
      > As a result, all the classes and resources from my war project are
      > packaged in a jar that is copied in the WEB-INF/lib directory of the
      > war artifact.
      >
      > But i don't understand why the war artifact still contains copy of the
      > classes and resources under WEB-INF/classes... Does anybody think that
      > i've misconfigured the war plugin ?
      >
      > Thanks for your help,
      >
      > Sebastien
      >
      >


      View this message in context: http://www.nabble.com/Configuring-war-plugin-for-using-a-jar-instead-of-WEB-INF-classes-tf2589199s177.html#a7219855
      Sent from the Maven - Users mailing list archive at Nabble.com.

      ---------------------------------------------------------------------
      To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
      For additional commands, e-mail: users-help@maven.apache.org

        Attachments

          Activity

            People

            • Assignee:
              snicoll Stephane Nicoll
              Reporter:
              sbrunot@ilog.fr Sebastien Brunot
            • Votes:
              2 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: