Maven WAR Plugin
  1. Maven WAR Plugin
  2. MWAR-263

filteringDeploymentDescriptors does not filter all deployment descriptors

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not A Problem
    • Affects Version/s: 2.1.1
    • Fix Version/s: None
    • Component/s: filtering
    • Labels:
      None

      Description

      I have set the optional configuration parameter <filteringDeploymentDescriptors> to true. It only filters web.xml. But i believe it should also filter the provider specific descriptors like jboss-web.xml.

        Activity

        Xin Zoo created issue -
        Dennis Lundberg made changes -
        Field Original Value New Value
        Component/s filtering [ 15263 ]
        Dennis Lundberg added a comment -

        The plugin currently filters two deployment descriptors, web.xml and a user configurable descriptor. The latter needs to be configured using the containerConfigXML parameter, which should point to the container specific file. In your case jboss-web.xml.

        Dennis Lundberg made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Not A Bug [ 6 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 13:28:45 UTC 2015 [ 1428240525159 ]
        Mark Thomas made changes -
        Workflow jira [ 12728673 ] Default workflow, editable Closed status [ 12764784 ]
        Mark Thomas made changes -
        Project Import Mon Apr 06 01:49:55 UTC 2015 [ 1428284995525 ]
        Mark Thomas made changes -
        Workflow jira [ 12966284 ] Default workflow, editable Closed status [ 13002237 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        364d 13h 25m 1 Dennis Lundberg 25/Sep/12 17:58

          People

          • Assignee:
            Unassigned
            Reporter:
            Xin Zoo
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development