Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not A Problem
    • Affects Version/s: 2.0.2, 2.1-alpha-1
    • Fix Version/s: None
    • Component/s: manifest, overlay
    • Labels:
      None
    • Environment:
      maven 2.0.7

      Description

      Despite the fact that it is possible to generate a custom manifest as described in war-manifest-guide, it's not good enough when using the overlays mechanism. The maven-war-plugin can't take into account an existing manifest. It can just generate a new one with the corresponding configuration in the pom.

      However, if you use the overlays mechanism, you rather want to keep the manifest from your common war (see custom-manifest-war-overlays.zip in attachment).

        Issue Links

          Activity

          Sanlaville Rémy created issue -
          Olivier Lamy (*$^¨%`£) made changes -
          Field Original Value New Value
          Link This issue depends upon MWAR-31 [ MWAR-31 ]
          Dennis Lundberg added a comment -

          I had a look at you attachment, but I don't understand your use case.
          Can you explain some more what you want to do and why?

          Stephane Nicoll made changes -
          Component/s overlay [ 14514 ]
          Dennis Lundberg made changes -
          Component/s manifest [ 14515 ]
          Gabriela Chiribau added a comment - - edited

          please delete - the manifest works, it just looks different

          Olivier Lamy (*$^¨%`£) added a comment -

          close issue as requested by reporter.

          Olivier Lamy (*$^¨%`£) made changes -
          Assignee Olivier Lamy [ olamy ]
          Resolution Not A Bug [ 6 ]
          Status Open [ 1 ] Closed [ 6 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 13:28:45 UTC 2015 [ 1428240525159 ]
          Mark Thomas made changes -
          Workflow jira [ 12728556 ] Default workflow, editable Closed status [ 12764899 ]
          Mark Thomas made changes -
          Project Import Mon Apr 06 01:49:55 UTC 2015 [ 1428284995525 ]
          Mark Thomas made changes -
          Workflow jira [ 12966467 ] Default workflow, editable Closed status [ 13002823 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          1969d 21h 30m 1 Olivier Lamy (*$^¨%`£) 01/Jul/13 08:51

            People

            • Assignee:
              Olivier Lamy (*$^¨%`£)
              Reporter:
              Sanlaville Rémy
            • Votes:
              4 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development