Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.1
    • Fix Version/s: 2.2
    • Component/s: None
    • Labels:
      None

      Description

      Instead of emitting "Reloading app", it emits "Redeploying app". I have patched the issue.

      1. ASF.LICENSE.NOT.GRANTED--MTOMCAT-84.patch
        0.6 kB
        Michael Osipov
      2. MTOMCAT-84.patch
        0.5 kB
        Michael Osipov

        Activity

        Olivier Lamy (*$^¨%`£) added a comment -

        we use tomcat manager reload url so the message looks correct for me.

        Konstantin Kolinko added a comment -

        Where is the patch? I get an error trying to download it as if it has been deleted.

        I think the issue is that ReloadMojo in Tomcat 6 plugin uses wrong message key.

        getLog().info( messagesProvider.getMessage( "RedeployMojo.redeployApp", ...

        It should use its own "ReloadMojo.reloadingApp".

        Michael Osipov added a comment -

        Olivier Lamy (*$^¨%`£), I don't think so.

        Konstantin Kolinko, I have reuploaded the patch. I have signed ASF license months ago.

        Olivier Lamy (*$^¨%`£) added a comment -

        patch applied.
        Thanks

        Hudson added a comment -

        SUCCESS: Integrated in TomcatMavenPlugin-mvn3.x #267 (See https://builds.apache.org/job/TomcatMavenPlugin-mvn3.x/267/)
        MTOMCAT-84 tomcat:reload logs the wrong message
        Submitted by Michael Osipov. (olamy: http://svn.apache.org/viewvc/?view=rev&rev=1539191)

        • /tomcat/maven-plugin/trunk/tomcat6-maven-plugin/src/main/java/org/apache/tomcat/maven/plugin/tomcat6/ReloadMojo.java

          People

          • Assignee:
            Olivier Lamy (*$^¨%`£)
            Reporter:
            Michael Osipov
          • Votes:
            1 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development