Uploaded image for project: 'Apache Tomcat Maven Plugin'
  1. Apache Tomcat Maven Plugin
  2. MTOMCAT-316

Server stuck at starting ProtocolHandler

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Blocker
    • Resolution: Unresolved
    • Affects Version/s: 2.2
    • Fix Version/s: None
    • Component/s: tomcat7
    • Labels:
      None
    • Environment:
      Mac OS X 10.13.6
      (Using Java 8 and running the plugin from IntelliJ IDEA)

      Description

      Hi, I'm trying to use the Tomcat Maven Plugin to launch a webapp of mine into an embedded Tomcat server. I can correctly import the plugin via my pom.xml file and launch the tomcat7:run goal, but the server seems to hang at these lines I see in the logs:

      set 07, 2018 9:16:09 AM org.apache.coyote.AbstractProtocol start
      INFORMAZIONI: Starting ProtocolHandler ["http-bio-8080"]

      After this point, nothing happens, even after several minutes. I tried launching the same application by deploying it on a locally installed Tomcat (versions 7, 8 and 9) and I have no problems at all. 

      I also tried changing the protocol handler (to use the "nio" one instead of the "bio") from the plugin configuration in my pom.xml, but although the protocol handler is correctly set, nothing changes.

      I tried with both Maven 3 and Maven 2, but nothing seems to change. I even tried using the older Tomcat 6 Maven Plugin, but it still gets stuck. 

      Any idea about what might be causing this behavior? what other information should I provide to make the issue clearer? )-:

        Attachments

        1. image.jpg
          122 kB
          Grant Phillip Goraczkowski

          Activity

            People

            • Assignee:
              olamy Olivier Lamy
              Reporter:
              walter.paganini Walter Paganini
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated: