Apache Tomcat Maven Plugin
  1. Apache Tomcat Maven Plugin
  2. MTOMCAT-245

Missing useBodyEncodingForURI parameter on connector

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: 2.2
    • Component/s: tomcat6, tomcat7
    • Labels:
      None

      Description

      UseBodyEncodingForURI is unsupported yet (25 oct 2013) in 2.2-SNAPSHOT. Please add it:

      tomcat7-maven-plugin/src/main/java/org/apache/tomcat/maven/plugin/tomcat7/run/AbstractRunMojo.java

      @Parameter( property = "maven.tomcat.useBodyEncodingForURI", defaultValue = "false" )
      private boolean useBodyEncodingForURI;

      then next to "connector.setURIEncoding( uriEncoding );", add
      connector.setUseBodyEncodingForURI( useBodyEncodingForURI );

      then next to "ajpConnector.setURIEncoding( uriEncoding );", add
      ajpConnector.setUseBodyEncodingForURI( useBodyEncodingForURI );

        Activity

        Hide
        Hudson added a comment -

        UNSTABLE: Integrated in TomcatMavenPlugin-mvn3.x #259 (See https://builds.apache.org/job/TomcatMavenPlugin-mvn3.x/259/)
        MTOMCAT-245 Missing useBodyEncodingForURI parameter on connector
        Submitted by Cédric Dutoit
        for tomcat6 plugin too (olamy: http://svn.apache.org/viewvc/?view=rev&rev=1537807)

        • /tomcat/maven-plugin/trunk/tomcat6-maven-plugin/src/main/java/org/apache/tomcat/maven/plugin/tomcat6/AbstractRunMojo.java
          MTOMCAT-245 Missing useBodyEncodingForURI parameter on connector
          Submitted by Cédric Dutoit (olamy: http://svn.apache.org/viewvc/?view=rev&rev=1537804)
        • /tomcat/maven-plugin/trunk/tomcat7-maven-plugin/src/main/java/org/apache/tomcat/maven/plugin/tomcat7/run/AbstractRunMojo.java
        Show
        Hudson added a comment - UNSTABLE: Integrated in TomcatMavenPlugin-mvn3.x #259 (See https://builds.apache.org/job/TomcatMavenPlugin-mvn3.x/259/ ) MTOMCAT-245 Missing useBodyEncodingForURI parameter on connector Submitted by Cédric Dutoit for tomcat6 plugin too (olamy: http://svn.apache.org/viewvc/?view=rev&rev=1537807 ) /tomcat/maven-plugin/trunk/tomcat6-maven-plugin/src/main/java/org/apache/tomcat/maven/plugin/tomcat6/AbstractRunMojo.java MTOMCAT-245 Missing useBodyEncodingForURI parameter on connector Submitted by Cédric Dutoit (olamy: http://svn.apache.org/viewvc/?view=rev&rev=1537804 ) /tomcat/maven-plugin/trunk/tomcat7-maven-plugin/src/main/java/org/apache/tomcat/maven/plugin/tomcat7/run/AbstractRunMojo.java
        Hide
        Olivier Lamy (*$^¨%`£) added a comment -

        apply
        Thanks for the patch.

        Show
        Olivier Lamy (*$^¨%`£) added a comment - apply Thanks for the patch.

          People

          • Assignee:
            Olivier Lamy (*$^¨%`£)
            Reporter:
            Cédric Dutoit
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 1h
              1h
              Remaining:
              Remaining Estimate - 1h
              1h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development