Apache Tomcat Maven Plugin
  1. Apache Tomcat Maven Plugin
  2. MTOMCAT-143

contextFile and tomcatUsers defined in pom.xml are not used with target tomcat7:run

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: tomcat7
    • Labels:
      None
    • Environment:
      linux

      Description

      In the configuration of the plugin into my pom.xml, I've defined the path to the contextFile and the tomcatUsers like this :

      <contextFile>$

      {appdir}/context.xml</contextFile>
      <tomcatUsers>${appdir}

      /tomcat-users.xml</tomcatUsers>

      It works using version 2.0-beta-1 and worked with 2.0-SNAPSHOT until a few days ago. Tomcat7 start correctly, but my tomcat-users.xml is not used and I cannot authentied services deployed on my tomcat. I use this configuration with jenkins for testing.

      Is there a regression in 2.0-SNAPSHOT or a new configuration issue ?

        Activity

        Olivier Lamy (*$^¨%`£) made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Olivier Lamy (*$^¨%`£) made changes -
        Field Original Value New Value
        Fix Version/s 2.0 [ 12319450 ]
        Raphaël Zürcher created issue -

          People

          • Assignee:
            Olivier Lamy (*$^¨%`£)
            Reporter:
            Raphaël Zürcher
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development