Maven Source Plugin
  1. Maven Source Plugin
  2. MSOURCES-30

Should not output INFO message when maven is run in quiet mode

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.4
    • Fix Version/s: 2.2
    • Labels:
      None

      Description

      Currently, the source plugin produces INFO statement for created source jars even if maven is run in quite mode.

      This produces unwanted output to system.out during build.

        Activity

        Hide
        Olivier Lamy (*$^¨%`£) added a comment -

        upgrade to last plexus-archiver and plexus-utils.

        Show
        Olivier Lamy (*$^¨%`£) added a comment - upgrade to last plexus-archiver and plexus-utils.
        Hide
        Paul Gier added a comment -

        This should be fixed with the next release of plexus archiver.
        See commit 955c1827.

        Show
        Paul Gier added a comment - This should be fixed with the next release of plexus archiver. See commit 955c1827 .
        Hide
        Evgeny Mandrikov added a comment -

        Seem that update of plexus-archiver to 2.0.1 (PLXCOMP-129) and plexus-utils to 3.0 doesn't solve this issue :

        Apache Maven 2.2.1 (r801777; 2009-08-06 23:16:01+0400)
        Java version: 1.6.0_29
        Java home: /opt/sun-jdk-1.6.0.29/jre
        Default locale: ru_RU, platform encoding: UTF-8
        OS name: "linux" version: "2.6.39.3" arch: "i386" Family: "unix"
        [INFO] Scanning for projects...
        [INFO] snapshot org.apache.maven.plugins:maven-source-plugin:2.1.3-SNAPSHOT: checking for updates from central
        [INFO] ------------------------------------------------------------------------
        [INFO] Building Sonar :: Plugins :: Findbugs
        [INFO]    task-segment: [source:jar-no-fork]
        [INFO] ------------------------------------------------------------------------
        [INFO] [source:jar-no-fork {execution: default-cli}]
        [INFO] org already added, skipping
        [INFO] org/sonar already added, skipping
        [INFO] org/sonar/plugins already added, skipping
        [INFO] org/sonar/plugins/findbugs already added, skipping
        [INFO] ------------------------------------------------------------------------
        [INFO] BUILD SUCCESSFUL
        [INFO] ------------------------------------------------------------------------
        [INFO] Total time: 5 seconds
        [INFO] Finished at: Sat Nov 12 00:54:35 MSK 2011
        [INFO] Final Memory: 17M/117M
        [INFO] ------------------------------------------------------------------------
        
        Show
        Evgeny Mandrikov added a comment - Seem that update of plexus-archiver to 2.0.1 (PLXCOMP-129) and plexus-utils to 3.0 doesn't solve this issue : Apache Maven 2.2.1 (r801777; 2009-08-06 23:16:01+0400) Java version: 1.6.0_29 Java home: /opt/sun-jdk-1.6.0.29/jre Default locale: ru_RU, platform encoding: UTF-8 OS name: "linux" version: "2.6.39.3" arch: "i386" Family: "unix" [INFO] Scanning for projects... [INFO] snapshot org.apache.maven.plugins:maven-source-plugin:2.1.3-SNAPSHOT: checking for updates from central [INFO] ------------------------------------------------------------------------ [INFO] Building Sonar :: Plugins :: Findbugs [INFO] task-segment: [source:jar-no-fork] [INFO] ------------------------------------------------------------------------ [INFO] [source:jar-no-fork {execution: default-cli}] [INFO] org already added, skipping [INFO] org/sonar already added, skipping [INFO] org/sonar/plugins already added, skipping [INFO] org/sonar/plugins/findbugs already added, skipping [INFO] ------------------------------------------------------------------------ [INFO] BUILD SUCCESSFUL [INFO] ------------------------------------------------------------------------ [INFO] Total time: 5 seconds [INFO] Finished at: Sat Nov 12 00:54:35 MSK 2011 [INFO] Final Memory: 17M/117M [INFO] ------------------------------------------------------------------------
        Hide
        Vincent Latombe added a comment -

        Depends on PLXCOMP-129

        Show
        Vincent Latombe added a comment - Depends on PLXCOMP-129
        Hide
        jieryn added a comment -

        Ping!

        Show
        jieryn added a comment - Ping!
        Hide
        jieryn added a comment -

        Moving from 2.1.1 to 2.1.2 my output has more than 8x expanded because of hundreds of these messages being issued. I think I could tolerate INFO level for the first (for any duplicate resource) " [INFO] path/to/resource already added, skipping "; but the exact same warning is issued 30 or 40 times during the build process. This is quite intolerable, and as you say Dennis, there is apparently no work around because it is a dependency issuing the messages.. Please help!!

        Show
        jieryn added a comment - Moving from 2.1.1 to 2.1.2 my output has more than 8x expanded because of hundreds of these messages being issued. I think I could tolerate INFO level for the first (for any duplicate resource) " [INFO] path/to/resource already added, skipping "; but the exact same warning is issued 30 or 40 times during the build process. This is quite intolerable, and as you say Dennis, there is apparently no work around because it is a dependency issuing the messages.. Please help!!
        Hide
        Dennis Lundberg added a comment -

        The logging statement comes from a dependency of the Source Plugin: Plexus Archiver.

        Show
        Dennis Lundberg added a comment - The logging statement comes from a dependency of the Source Plugin: Plexus Archiver.

          People

          • Assignee:
            Olivier Lamy (*$^¨%`£)
            Reporter:
            Mauritz Lovgren
          • Votes:
            9 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development