Uploaded image for project: 'Maven Site Plugin'
  1. Maven Site Plugin
  2. MSITE-153

Paragraphs after list being "dropped" by site generation

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0-beta-5
    • Fix Version/s: 2.0-beta-5
    • Component/s: None
    • Labels:
      None

      Description

      When generating the Struts site, in some circumstances, the paragraphs that follow a list are disappearing from the generated document - the number of paragraphs dropped corresponds to the number of items in the list.

      So if in the XML document I have something like the following, with 3 items in a list:

      <ul>
      <li>Item 1</li>
      <li>Item 2</li>
      <li>Item 3</li>
      </lu>

      Then the first three paragraphs following the list disappear - see the list of shale committers:
      http://struts.apache.org/announce.html

      I have re-produced this in a simple test document which I'll attach - along with the output from running "mvn site"

        Attachments

        1. mvn-site-output.txt
          41 kB
          Niall Pemberton
        2. test.html
          8 kB
          Niall Pemberton
        3. test.xml
          1 kB
          Niall Pemberton

          Issue Links

            Activity

              People

              • Assignee:
                siveton Siveton Vincent
                Reporter:
                niallp Niall Pemberton
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: