Maven Site Plugin
  1. Maven Site Plugin
  2. MSITE-130

Site generation fails for site.xml in UTF8 with BOM

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0-beta-6
    • Component/s: encoding
    • Labels:
      None

      Description

      I get the following error if I edit site.xml with Windows Notepad.

      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Error during page generation

      Embedded error: Can't read site descriptor.
      only whitespace content allowed before start tag and not \uef (position: START_DOCUMENT seen \uef... @1:1)

      This is due to http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=4508058 . Since Sun is saying they won't fix this "RFE" (which I think is a bug), we need a workaround.

        Issue Links

          Activity

          Shinobu Kawai created issue -
          Brett Porter made changes -
          Field Original Value New Value
          Fix Version/s 2.0-beta-7 [ 13092 ]
          Hervé Boutemy made changes -
          Link This issue is superceded by MSITE-239 [ MSITE-239 ]
          Hervé Boutemy added a comment -

          the problem is more general: encoding support for site.xml

          Dennis Lundberg made changes -
          Component/s encoding [ 12941 ]
          Hervé Boutemy added a comment -

          XML encoding support is fixed for site.xml and every xdoc file, fml, and so on
          to be precise, BOM is supported for UTF-8 and UTF-16, but not UTF-32

          Hervé Boutemy made changes -
          Assignee Herve Boutemy [ hboutemy ]
          Fix Version/s 2.0-beta-7 [ 13092 ]
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Closed [ 6 ]
          Fix Version/s 2.0-beta-6 [ 12151 ]
          Lukas Theussl made changes -
          Link This issue is related to DOXIA-452 [ DOXIA-452 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 13:16:22 UTC 2015 [ 1428239782088 ]
          Mark Thomas made changes -
          Workflow jira [ 12726524 ] Default workflow, editable Closed status [ 12757291 ]
          Mark Thomas made changes -
          Project Import Mon Apr 06 01:19:02 UTC 2015 [ 1428283142430 ]
          Mark Thomas made changes -
          Workflow jira [ 12964265 ] Default workflow, editable Closed status [ 13001289 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          568d 18h 50m 1 Hervé Boutemy 01/Dec/07 06:07

            People

            • Assignee:
              Hervé Boutemy
              Reporter:
              Shinobu Kawai
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development